tuncfg & HamachiX console loop

A strange behaviour in my Console, which I discovered when starting Console rather than terminal by accident. The Tuncfg process was quitting and restarting constantly as it tried to establish a connection to the Hamachi server. What this meant when behind a Firewall was it would loop while trying; pinging messages into the Console app.

I have not used Hamachi or HamachiX in ages, so had to find a way to turn this sucker off. The solution was in a blog post by Fernieville, on Jan 30th 08.

This is non-wow related, and specific to Macs (bye). Basically uninstalling the Hamachi components using an option in the Help menu of HamachiX. Which is pretty dumb imho, as you’d think that would be exposed as a preference, rather than in Help.

What is also interesting is that the new version of HamachiX seems to fix a “network connection exit” error, but had no affect on this on my system. So I upgraded then uninstalled the components. Job Done.

From Fernieville:

So in my Console log files it looked like this:

1/29/08 11:39:54 PM tuncfgd[6864] tuncfg: already running, use ‘killall tuncfg; tuncfg’ to restart it
1/29/08 11:39:54 PM com.apple.launchd[1] (tuncfgd[6864]) Exited with exit code: 1
1/29/08 11:39:54 PM com.apple.launchd[1] (tuncfgd) Throttling respawn: Will start in 10 seconds
1/29/08 11:40:04 PM tuncfgd[6865] tuncfg: already running, use ‘killall tuncfg; tuncfg’ to restart it
1/29/08 11:40:04 PM com.apple.launchd[1] (tuncfgd[6865]) Exited with exit code: 1
1/29/08 11:40:04 PM com.apple.launchd[1] (tuncfgd) Throttling respawn: Will start in 10 seconds

So here is the solution:

Open HamachiX

Go into Help, System Support, Uninstall System Components

Now you can uninstall Hamachi if you want, if not, you’ll have to install every time you want to use it. Editing the tuncfgd.plist (from Apple Help forums) didn’t work even after rebooting and restarting launchd.

Hope this helps!

Indeed it did – thanks! Incidentally we’re also using the same blog theme, so good taste there too.

Advertisements

4 thoughts on “tuncfg & HamachiX console loop

  1. this was a great tip to solve a problem i didn’t know i had until i opened console. no idea how long it’s been going on …

  2. Thanks for this fix. I’ve probably been getting that error since before this post, probably for over a year now. But I didn’t know about it until I just now accidentally opened the console instead of iterm…

Comments are closed.